[WPMU DEV Dashboard] WPMU DEV Dashboard Plugin Issues

I’m constantly getting emails that this site is down and that it’s back online. Many times this has occured while I’m logged in to the site.
Here’s the latest email I received for this site that I think is related to this issue:

Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, WPMU DEV Dashboard.

First, visit your website (https://imarketsupport.com/) and check for any visible issues. Next, visit the page where the error was caught (https://imarketsupport.com/wp-login.php?action=register) and check for any visible issues.

Please contact your host for assistance with investigating this issue further.

If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

Error Details
=============

An error of type E_ERROR was caused in line 141 of the file /home/nusolna11m3/public_html/support.imarketmarketing.com/wp-content/plugins/wpmudev-updates/update-notifications.php. Error message: Uncaught Error: Class 'WPMUDEV_Dashboard_Remote' not found in /home/nusolna11m3/public_html/support.imarketmarketing.com/wp-content/plugins/wpmudev-updates/update-notifications.php:141
Stack trace:
#0 /home/nusolna11m3/public_html/support.imarketmarketing.com/wp-content/plugins/wpmudev-updates/update-notifications.php(116): WPMUDEV_Dashboard->__construct()
#1 /home/nusolna11m3/public_html/support.imarketmarketing.com/wp-content/plugins/wpmudev-updates/update-notifications.php(225): WPMUDEV_Dashboard::instance()
#2 /home/nusolna11m3/public_html/support.imarketmarketing.com/wp-settings.php(376): include_once('/home/nusolna11...')
#3 /home/nusolna11m3/public_html/support.imarketmarketing.com/wp-config.php(109): require_once('/home/nusolna11...')
#4 /home/nusolna11m3/public_html/support.imarketmarketing.com/wp-load.php(37): require_once('/home/nusolna11...')
#5 /home/nusolna11m3/public_html/support.imarketmarketing.com/wp-login.php(12): require('/home/nusolna11...')
#6 {main}
thrown

I was having high CPU issues on another website and found this plugin to be having issues. Once I removed this plugin those issues went away.
Any responses appreciated