[WPMU DEV Dashboard] WPMU DEV Dashboard V4.4 Prevents WP Remote from finding Updates

WPMU DEV Dashboard V4.4 Prevents WP Remote from finding Updates.
I did have a ticket on WP remote and the dashboard not letting WP Remote connect to the site and since was fixed with a Dashboard update.
This problem is its connecting but not seeing the plugins that need to be updated.
I disabled all plugins one at a time and left WPMU DEV Dashboard V4.4 alone and cleared cache and cloudflare cache waiting a few minutes and then checked again and WP Remote was still not finding plugin updates. then I disabled WPMU DEV Dashboard and it found all updates. I updated and waited for another group of plugins and it still was happening.
I have activated this in wpconfig for me to check in one the next time we have a lot of updates
// Enable WP_DEBUG mode
define(\'WP_DEBUG\', true);

// Enable Debug logging to the /wp-content/debug.log file
define(\'WP_DEBUG_LOG\', true);

// Disable display of errors and warnings
define(\'WP_DEBUG_DISPLAY\', false);

//Enable WPMU DEV Dashboard debug
define(\'WPMUDEV_API_DEBUG\', true);
I will update this ticket when I have the results of the logs if any.
Also this is what I have for php.ini
max_execution_time = 5,000
max_input_time = 800
max_input_vars = 6000
memory_limit = 2000M
upload_max_filesize = 2000M

Also for wp config
// Enable WP_DEBUG mode
define(\'WP_DEBUG\', true);

// Enable Debug logging to the /wp-content/debug.log file
define(\'WP_DEBUG_LOG\', true);

// Disable display of errors and warnings
define(\'WP_DEBUG_DISPLAY\', false);

//Enable WPMU DEV Dashboard debug
define(\'WPMUDEV_API_DEBUG\', true);

//@ini_set(\'display_errors\', 0);
define( \'SUNRISE\', \'on\' );
define(\'WP_ALLOW_MULTISITE\', true);
define(\'MULTISITE\', true);
define(\'SUBDOMAIN_INSTALL\', true);
$base = \'/\';
define(\'DOMAIN_CURRENT_SITE\', \'aresnyc.org\');
define(\'PATH_CURRENT_SITE\', \'/\');
define(\'SITE_ID_CURRENT_SITE\', 1);
define(\'BLOG_ID_CURRENT_SITE\', 1);
define(\'RECENT_GLOBAL_POSTS_WIDGET_MAIN_BLOG_ONLY\', false);
define( \'WP_MEMORY_LIMIT\', \'1024M\' );
define( \'WP_MAX_MEMORY_LIMIT\', \'1024M\' );

If you need any other info let me know
Mitch

  • Majid
    • Syntax Hero

    Hello HamRadioDude
    I hope you are doing great :slight_smile:

    I wasn't able to replicate the issue on my, using WP Remote I could update bunch of outdated plugins on one of my site with WPMU DEV dashboard (v4.4) plugin installed and active.

    So yes, please update this thread with any information that might be useful from the debug.log file.

    Thank you
    Majid

  • HamRadioDude
    • HummingBird

    An Update for Contact Form 7 Has been released All Sites where updated in WP_Remote and the Multisite AresNYC.org did not show at all needing a update for Contact Form 7.

    I verified the Multisite saw the update.

    I verified that My Hub Does See the needed Update.

    I checked for a error.log there was None
    I checked in wp-content for a debug log there was none

  • Dimitris
    • Support Star

    Hello there HamRadioDude,

    hope you're doing good today! :slight_smile:

    I've just tried to replicate this case with the specific plugin (Contact Form 7), but I wasn't able to, as I can see the update notification in WP admin area, WP Remote and WPMUDEV Hub.


    You've mentioned that you've conducted a conflict test already around other plugins, so I guess that this is either a matter of caching (you've mentioned server cache and Cloudflare), as well as of a theme conflict.
    Could you please first try to deactivate any caching involving to this installation and recheck website in WP Remote?
    If this has no result, try to activate a default theme like TwentySeventeen too (backup your database first, in case you lose any settings during the tests) and check WP Remote once more.

    Warm regards,
    Dimitris

  • Dimitris
    • Support Star

    Have you tried the theme conflict test? Please advise!

    If this has no result, try to activate a default theme like TwentySeventeen too (backup your database first, in case you lose any settings during the tests) and check WP Remote once more.

    You can also try to exclude Cloudflare's caches temporarily, by activating development mode as described below:
    https://support.cloudflare.com/hc/en-us/articles/200168246-What-does-Cloudflare-Development-mode-mean-

    Warm regards,
    Dimitris

  • Dimitris
    • Support Star

    Hello there HamRadioDude,

    hope you're doing good today! :slight_smile:

    I just tried to replicate this in another live installation, this time a WP multisite, using Domain Mapping plugin like your case, but I was still unable to replicate. :confused:


    As we should narrow this down somehow and find the source of it, could you please try to create a new testing WP site in the same server, using another domain (or subdomain) and try to replicate this issue once more? We could then use this installation as a testing ground. Please do proceed with this creation and let me know, if the same issue is replicable, so I could provide a safe way to send us over some access details.

    Warm regards,
    Dimitris

  • HamRadioDude
    • HummingBird

    You have to be kidding me you want be to create a multisite with domain mapping with domains I do not have. and Time to do this I do not have.
    I have had about enough of this If I disable the Dashboard plugin it will work what part of that are you missing.
    I had this type of problem before and an update fixed it.
    Hay here's an idea Maybe ask the developer for help!!!

  • Dimitris
    • Support Star

    Hey there HamRadioDude,

    hope you're doing good today! :slight_smile:

    You have to be kidding me you want be to create a multisite with domain mapping with domains I do not have. and Time to do this I do not have.

    I didn't mention mapped domains, a simple multisite in the same server using the same plugins and settings could have been enough, as long as the issue is reproducible.

    I have had about enough of this If I disable the Dashboard plugin it will work what part of that are you missing.

    What's missing are some replication steps actually, as we were unable to replicate this during our tests. You may resolve this in your end, by disabling WPMUDEV Dashboard, but the source of this may be some other plugin/code/setting.

    And I did make sure the wp-config was correct.

    Good to know! :slight_smile:

    Fixed Itemes Security Setting. I forgot the setting played with all of them I think it was something to do with wp-config. I deleted Ithemes Security and went with Wordfence.

    So is this resolved by now? Was that some conflict with iTheme Security? Please advise!

    Warm regards,
    Dimitris

  • HamRadioDude
    • HummingBird

    Yes it was iTheme Security. Whats bugging me I shut off all plugins except wp-remote and the dashboard. then when the dashboard was shut it worked. I tested before and after.
    Might have been something that was written in htaccess with iTheme Security when I disabled it this time it took it out.
    BUt whatever it was it fixed now.
    thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.