wpmu dev fundraiser plugin problem pledges not logging

We are successfully receiving donations, they are appearing in our pay pal account and we are receiving email notification about them, but they are not appearing in our pledges account and are not automatically updating and logging to show that we have supporters and money coming in.

I have bluehost.

It is live, not in sandbox mode.

My IPN return is on.
My API info seems to match.

  • Alexander

    Hi @ASOTRECOL,

    Can you let me know if this is with Simple donations, or the advanced crowdfunding?

    Also, can you try enabling debug logging on your site? Take the code from this snippet and add it to your wp-config.php file: http://git.io/gJANNQ

    Then wait for some more donations to come through. You should have a debug.log file in the wp-content folder. We can check this for errors to see if there are any problems with the IPN.

    Once logging is enabled, and you're sure some donations have gone through but weren't logged, can you email me that log file?
    Just send to contact [at] wpmudev.org
    - Include my name in the subject "Alexander Rohmann"
    - Include a link back to this thread
    - Attach the log file

    Best regards,

  • Alexander

    Hi @ASOTRECOL,

    Did you add it after the opening PHP tag? <?php It would need to go after this. Also, it's possible that you already have debug mode defined in wp-config.php If this is true, you could be turning it on at the beginning, but then off again later. Can you double check this?

    Also, it wouldn't be a debug folder. Rather a file named debug.log (it's like a text file) located in the wp-content directory.

    Hopefully this clears some things up!

    Best regards,

  • Alexander

    Hi @ASOTRECOL,

    I see you responded to the email notification. I'll just update the ticket here. The messages you've mentioned are actually harmless. These are debug messages to assist developers, not errors. An error would be tagged "Fatal Error" or sometime an error could come through as a "warning"

    Did you try with debug logging on? You should have a file in your wp-content folder called debug.log? If you don't have one, it probably means that debug logging hasn't been enabled. If it's not there, try adding this to your wp-config.php file in place of any other debug code you have added:
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);

    if(defined('WP_DEBUG_LOG') && WP_DEBUG_LOG == true) {
    @ini_set('display_errors',0); //Prevent PHP from displaying errors
    define('WP_DEBUG_DISPLAY', false); //Prevent Wordpress errors from being displayed
    }
    Then try another donation and see if a log is recorded. If we don't have any errors this time, it's likely that PayPal is not reaching your site at all.

    Can you also confirm that you've added the correct IPN url in your PayPal settings? It would like something like this:
    http://yoursite.com/wp-admin/admin-ajax.php?action=wdf-ipn-return-paypal

    Let me know what you find out!

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.