WPMU Dev SEO SEOmoz plug-in gets API error and provides no stats

The SEO plug-in is installed on my single-site WordPress 3.2.1 installation with MySQL 5.0 back-end database. I've gone to the SEOmoz.org site, signed up for an account, and received an Access ID and secret key from their site for the Free API. I've copied and pasted those values into the SEO plug-in and saved them. It immediately comes back with:

Unable to retrieve data from the SEOmoz API. Error: .

The SEOmoz displays on individual posts/pages are blank as well.

The other features of the plug-in seem to work fine, but I'm having no luck with this one.

  • DavidM
    • DEV MAN’s Mascot

    Hi msalsbury,

    That error usually comes up only when the Access ID and Secret Key are entered incorrectly. Could you please double check that they’re correctly pasted, without any additional space characters?

    Also, have you allowed a bit of time for the key to propagate the SEOMoz servers? It can take a few minutes.

    Thanks,

    David

  • Philip John
    • DEV MAN’s Apprentice

    Hiya,

    As we haven’t heard back from you we’re going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn’t resolved, or you have any more questions related to this thread please feel free to post them below and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it’s a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.