WPMU Dixi, Nelo Triden with WP 3.2.1

Hi,
I just noticed new updates for these great themes. Thank you!

I'm not quit ready to update WP 3.2.1 to 3.3.1. Can they be used with 3.2.1 using Multi-DB?
Thanks,
Chuck S.