WPMU Membership crashes home page of greeneconomygroup.com

Dear WPMU team:
I recently upgraded from version 3.4.5 to version 3.4.6 of WPMU's Membership plugin.
After installing it, the following things happened:
1. When entering greeneconomygroup.com the home page never loads and I get the following error message:
"The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete:

2. findsen.com began to have an error message on the front page which said: "Protected Content. The content you are trying to access is only available to members. Sorry."
3. lumihomes.com began to display the WP-login options in the upper left hand part of the screen (WP logo menu, "Login" and "Register"). These options were never there before and I don't want them there.
However, I have NOT activated WPMU Membership on any of these URLs so none of this should take place.
The only site I have activated WPMU Membership on is this: http://finance.greeneconomygroup.com/

At that URL WPMU Membership works as intended (in fact, it is AWESOME!).
I am hosting my sites with wpengine.com in a WP multi-user configuration and I rolled back the site to the Oct 19th version (one day before I installed the WPMU Membership plugin – on Oct 19th all sites were working flawlessly). In this way I am currently using WPMU Membership version 3.4.5. It is therefore kind of mysterious that I get the above-referenced results (i.e. the roll-back to the day before the installation of WPMU should have fixed things)
Do you know what is required to fix this?

  • geg

    Patrick,

    The Varnish cache insight was brilliant (especially because I think it's not widely known that WP Engine uses Varnish). I had worked with someone from WP Engine for an entire day who hadn't thought of that solution, but the moment we followed your suggestion, most of the problems were solved.

    Due to the issues described in my original message, I have currently downgraded from version 3.4.6 to version 3.4.5 of WPMU's Membership plugin.

    Before I attempt to upgrade to version 3.4.6, I would like to get a sense of why the issues that I described in my original messager occurred, whether these are common experiences for people who upgrade and whether any bugs have been fixed now so it's safe to upgrade – or if you recommend that I wait to upgrade.

    Thanks

  • Patrick

    Hi again @geg

    You're very welcome to any insight I may be able to provide. And thanks for the compliment. :slight_smile:

    WPEngine's Varnish cache can be extremely useful, but it can also be a PITA :slight_smile:

    Membership v3.4.6 was released only last week and it contains fixes for numerous issues & enhancements.

    I have successfully updated on several sites, no issues. But I don't have any sites hosted at WPEngine, nor do I use any cache plugins.

    My personal recommendation (and I may be talking outta my ear here) is to disable cache before any major plugin update. Then verify that everything is working properly before re-enabling cache.

    Updating with cache enabled will more than likely cause issues IMO.

    I hope this helps! And thanks for being a member :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.