WPMU Nelo: Update package not available

WPMU Nelo
You have version 2.1.6 installed. Update to 2.1.7.

An error occurred while updating WPMU Nelo: Update package not available..