[WPMU Product Sync (?) The first plug-in you want to install to install other plug-ins.] I cannot

I am trying to go through a demo to install social + plug-in and see if it works well.

I keep getting stuck on installing the "WPMU sync?" component.

First it tried to do it by itself and failed.
I log in and I see the plug in is installed but not activated.
I move to activate it, fill out the username and password
for my new WMPU demo account, I press login and
it thanks for a while and then it returns to the exact same
page prompting me to log in.

To check the password I attempted to login to the WMPU hub site with my username and password and that worked out fine.

I figured maybe the problem is one of my many security related plugins on Firefox so I tried doing the same thing in IE with the exact same result.

I dont know why it is failing or how to get around it.

I am wondering if it has to do with incompatible plug-ins on my site.
Is this due to WordFence being installed for instance?

  • Patrick Freitas

    Hi John Harry,

    How are you today?

    I’ve tried to replicate that error but I couldn’t. I was able to use our plugin without problem. However This might happen because of a conflict with another plugin on your site.

    Please, would't you mind please to provide a list of plugins you are using, so I can keep running more tests.

    However, wouldn’t you mind please run a plugin conflict test?

    Remember, it is important that you run this conflict test in a staging website or performance a full backup before it.

    Please deactivate all plugins except this one and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict.

    If you still having this issue, could you do a theme test, much the same as the plugin test, but now you’re testing themes!
    Activate one of the default WordPress themes, like Twenty Sixteen or Twenty Seventeen.
    Here you will find more information: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    If after this test you realize that Wordfence was the plugin with conflict I suggest you use our Defender Plugin:
    You can do that using our Defender Plugin https://premium.wpmudev.org/project/wp-defender/

    After the test please, let me know the results,
    Have a great day,
    Patrick Freitas

  • John Harry

    So I have tried installing the Product Sync on a different site, I
    was able to install sync without any difficulties even when
    I enabled the same theme and the same plug-ins on the new site
    so that should eliminate those as being the cause?

    I started the demo in order to try Comments +, is there a way I can
    download and install that without having the sync thing working?

    Or is the sync tool the only possible way to install Comments+?

    If so what else do I need to try to debug the sync tool?

    • Patrick Freitas

      Hi John Harry,

      How are you today?

      Good hear that you was able to install sync, is this running in the same environment? Web Hosting, PHP and WP version ?
      The WPMU DEV dashboard will provide to you many services, like Automate which will update the plugins and WordPress so it is important to be installed on WordPress.

      You can download the plugin in its page:
      https://premium.wpmudev.org/project/comments-plus/
      Right bellow Install button you will find the download link, it will download the zip file.

      To install go to WordPress Dashboard > Plugins > Install > Upload and Upload the zip file.

      Let us know if you have any further question,
      Have a great day
      Best Regards,
      Patrick Freitas

  • Patrick Freitas

    Hi John Harry

    Sorry I didn't realize that you are in the trial account, unfortunately the trial member are not allowed to download our plugin, however, I would recommend you active debug mode in WordPress and we can try to figure out what's going on with our plugin sync.

    Also wouldn't you mind to backup your site and run the plugin test in a stating environment of this website, sometimes any custom modification that you already did can be conflicting.

    To enable debug mode, please go to WordPress root folder search for wp-config.php and edit it. Right above * That's all, stop editing! Happy blogging. */ you past the code:

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    You can see our full article about how to enable debug mode: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    After enable debug mode, try to install the plugin again and check the wp-content folder for a debug.log file that has been generated and past the result here.

    Let me know the results,
    Have a great day,
    Patrick Freitas

  • John Harry

    Ok so I enabled the debug to a file and I dont see any interesting / relevant errors there in respect to WPMU sync plug-in. I compared the log between my Wordpress blog that works, and the one that did not and there was no obvious difference.

    I used a proxy to gawk at the informations / requests / responses sent from both of the sites without seeing anything that popped out to me.

    I attempted to delete and re-install the plug in without any interesting changes.

    What happens on the blog it doesnt work:

    1. Install the plug in (works fine)
    2. Activate the plug in (works fine)
    3. Logging in the plug in to my WPMU account does not work.
    It just returns the log in page again with no errors (even with DEBUG set to true).

    But if I enter the wrong password , the login page appears again but with a red field
    "Invalid Username or Password. Please try again"

    I take this to mean that the log-in with my credentials actually work (since it does not return an error) but for some reason the state is not updated with the plug-in (or I would get the super nice content page for managing my WPMU stuff).

    I have also tried to fully disable WordFence again but it made no difference, and again on the blog, it works on WordFence is already installed and working as well. I did a manual verification that the configuration of WordFence is the same on both of them.

    The theme is the same in both the blogs now.

    I know most of your stuff is really compatible, so I am very puzzled that it is not working,
    esp since it works on one.

    The hosting environment, the hosting provider, versions of WordPress is the same between both blogs.

  • Patrick Freitas

    Hi John Harry , wound't you please mind please send me some informations FTP and WP admin of both sites, so we can have a closer look?

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:
    Subject: "Attn: Patrick Freitas"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - WPMU dev login information
    - Link back to this thread for reference
    - Any other relevant urls/info

    Please reply this ticket when you have sent the informations and let us know for any further question.
    Have a great day,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.