[WPMU Product Sync (?) The first plug-in you want to install to install other plug-ins.] I cannot

I am trying to go through a demo to install social + plug-in and see if it works well.

I keep getting stuck on installing the "WPMU sync?" component.

First it tried to do it by itself and failed.

I log in and I see the plug in is installed but not activated.

I move to activate it, fill out the username and password

for my new WMPU demo account, I press login and

it thanks for a while and then it returns to the exact same

page prompting me to log in.

To check the password I attempted to login to the WMPU hub site with my username and password and that worked out fine.

I figured maybe the problem is one of my many security related plugins on Firefox so I tried doing the same thing in IE with the exact same result.

I dont know why it is failing or how to get around it.

I am wondering if it has to do with incompatible plug-ins on my site.

Is this due to WordFence being installed for instance?