WPMU setup

First- I tried to access the live support that was said to be online 0:00 am edt until 01:00 am edt 3/29 but says it is closed.

I followed WPMU setup option and it didn't work first time. I backed out and now when I add the wp-config line for multisite, it doesn't recognize it and show network under tools?

thx
Mike

  • Jack Kitterhing

    Hi there Mike,

    I hope you are well today.

    I'm sorry about the live support issue.

    This is the official codex here on setting up a WordPress multisite http://codex.wordpress.org/Create_A_Network

    Can you check in your wp-config.php that you have `/* Multisite */
    define('WP_ALLOW_MULTISITE', true);` ?

    Then in wp-admin > tools > you should see network setup.
    Is this a sub domain or sub directory site you are trying to install?

    Thank you.

    Kind Regards
    Jack.

  • Mike

    Jack- thanks for staying with me on this. A new day and I have done the following steps:

    0. backed up public_html of my production site and development site (that contains wp-config and htaccess

    1. added the define('WP_ALLOW_MULTISITE', true);
    to wp-config.php

    dev.mysite.com (development site) .

    2. logged in and setup/network was visible

    3. thinking success, I added the line in #1 to my wp-config for production site.

    4. It worked in that I see network option under tools but selecting network now gives me

    Warning: An existing WordPress network was detected.

    5. I exited out , no changes.
    6. accessed wp-config and removed line from dev.mysite.com , saved and exited, confirmed network is gone from dev (it is).
    7. re-accessed production site tools/network click and still giving
    Warning: An existing WordPress network was detected.

    8. I am choosing not to proceed any further until I can figure out what/why this is occurring.

    I have the following domains setup :

    http://www.mymainsite.com

    dev.mymainsite.com (sub-domain) for development
    mirror.mymainsite.com (sub-domain) a mirror of production for testing plugins, page changes, etc

    http://www.mytraining-ecommercesite.com this is where I really want to develop and use wpmu ecommerce tools, login, etc and V2.0 the existing CMS site .
    This site is set as an add-on domain and files are

    public_html/mytraining-ecommercesite.com

    I did install a base version of WP3.51 at this site, should I have done this?

    Right now all dev and mirror and mytraining all have their own version of wp3.51
    I copied mysql db down and up to the respecitve site db's to make the sites worked.
    I used a plugin I found to search/replace URL's for my dev and mirror sites.

    I have enabled wildcard domains per my web hosting provider (inMotion) and they do support WP MU.

    Thanks in advance for your help...

    Mike

  • Jack Kitterhing

    Hi there @Mike

    I hope you are well today.

    Where abouts are you adding the config details in network setup?

    They should be added above the line

    that's all, stop editing! Happy blogging. */".

    And not after it.

    Also it may be worth checking your database to see if the global tables all ready exist, if they do delete them and re-try, as you say you copied over the DB would it be possible for you to try with a fresh DB?

    Thanks! And have a great weekend!

    Kind Regards
    Jack.

  • Mike

    Jack- I am adding the entries just above the happy blogging lines.

    Here is what WP is telling me to enter..

    wp-config.php

    I removed the original line item for multi-site per instruction
    I will share my site URL once I get my WPMU enable ecommerce site active.

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.mymainsite.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    I tried entering the above htaccess lines inside

    <IfModule mod_rewrite.c>

    </IfModule>

    ..again w/o success

    What I do not understand is there is a difference from the above and what WPMU reports I should enter and other sites like my hosting provider inMotion.
    Frankly I do not really understand the line by line review of htaccess but this site did help.

    I strongly believe this has something to do with the htaccess rules bec. when I attempt to access the dashboard, it redirects me to the site.com/dir/wp-admin directory and it doesn't work.

    thanks

    Mike

  • Jack Kitterhing

    Hi there @Mike

    I hope you are well today.

    Do you error logs show anything at all?

    These are the .htaccess rules I use myself, they should replace all your other rules you have.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Try them, they may not work for you, but that's what I use on my personal sites :slight_smile:

    When you can't visit the dashboard, is it a 404 page not found or something else?

    Thank you!

    Kind Regards
    Jack.

  • Mike

    Jack- Yes I checked the db and all the tables were there. I , in fact, followed a link that walked you thru to de-Multi-sitify your site and then attempted to reinstall again with the same results.
    I strongly believe that my htaccess file is redirecting me to my ../dir/wp-admin directory and to answer your question I believe it was a 404 error bec. the php file is not there.

    Thanks for your support.

    Mike

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.