WPMU Spirit Theme problem - now I cannot even load it

I am having trouble with using your theme Spirit - I have a live, but not developed website fjcottrell.com and I have run up a localhost wordpress site on my Mac and I Installed Spirit on that site and was following the tutorials, but I could not get any pictures to display - I could not get a picture to load into a location as at the bottom at the white space there was only the upload button and that did not work, however I could get a picture into the background image as the select file button was there in that instance, but even though the picture showed up all the time after saving in the edit area, when going back to the actual site no picture was visible, I could only get different background colours to work.
So I decided to run the plugin to reset the database and I deleted all the wordpress files and put new ones back in place to start afresh. Then I installed the wpmu dashboard and then tried to download and install spirit, but now I just keep going round a loop of download and install and the only thing happening in that loop is a message that the site is not enabled for one click downloads, then when I click to change that I get a page showing both my FJCottrell and localhost site - I have localhost enabled there, but it just doesn't seem to do anything How do I get out of this situation so I can continue to learn how to operate your themes on my local machine in preparation to doing it on the live internet facing site of mine???

This is all getting really frustrating as I still doubt I will be able to get the pictures working and will need your help there as well, but I thought a total restart would be a good way to make sure I had not corrupted anything - seems now like a bad move as I am now stuck even getting the theme to load.
Regards,
Frank.

  • Predrag Dubajic

    Hi Frank,

    This surely sounds strange, are you able to grant support access on your live site so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    You can also manually install the theme by going to theme page https://premium.wpmudev.org/project/spirit/ download both Spirit and Upfront, unzip them and upload them to your wp-content/themes/ folder via FTP.

    Best regards,
    Predrag

  • Frank

    You are right - to me it is a strange problem, so first thought was to divide and conquer.
    I worked on your suggestions and learned about the downloading and installing, so I have the themes on my localhost all OK again for testing.... and I get the same problem, so...
    I decided that because my localhost is on a Macbook and behind Nat's etc. it could be difficult to get organized for you to log on remotely, considering time differences etc.
    So next step was to go to my web site, which is a Multisite installation with a test sub-site, so I enabled the Spirit theme there and it all worked just like in the tutorial for pictures and so I think I will concentrate on that site as it does not have anyone really looking at it yet and it will be more accessible if I need some more specific help.
    I will put my localhost site into the background for now and concentrate on the working website, so thanks for you help and I will leave this question closed now.
    Thanks, Frank.

  • Predrag Dubajic

    Hi Frank,

    Thanks for the additional info and I'm glad to hear that it's working on your live environment.

    Could you check what is the PHP version being used on your localhost and try using at least 5.4 to see if that will make any difference.
    I have MAMP setup on my Mac and didn't experience any issues with Upfront so far.

    If you do have other question we are here to help :slight_smile:

    Best regards,
    Predrag

  • Frank

    Hi Predrag,
    Thanks for the additional response.
    I checked PHP and it is at version 5.5.20 as I only recently got that download to setup.
    I figure it is not an issue with the database as I think more would have gone wrong if that was the case.
    Instead, I think my problem is rights related as I have had some problems loading up add-ons with errors trying to write to files.
    As soon as I get a chance, I will compare the security on all files and folders on both the internet installation and my localhost and I recon there is a good chance I will find the issue either there, or possibly with .htaccess maybe.
    The real telltale of the issue is that as soon as I go to add an image, the page goes out of focus and no load buttons appear - if I scroll down to the bottom of the page there is a white area that only on background image allows me to upload an image, but it never displays in the live web page, on in the design stage.
    Also when the page is out of focus, if I try to click into the tools area it always says not available when uploading media, but this state doesn't change, so I have to escape out of this state.
    I am sure there is a file, or folder security problem, but I will have to learn how to enable error messages to see if that can point me in the right direction.
    Again thanks for your assistance.
    Regards,
    Frank.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.