WPMU Tutorial – adding to Gridmarket

hello,

i was following the tutorial at : https://premium.wpmudev.org/blog/how-to-add-facebook-and-twitter-share-buttons-to-buddypress-profiles/

and when added to the gridmarket theme the icons don't align properly. i have attempted to add css styling to the images as sarah recommends in the comment section for padding the images but it moves the whole box (including text) down instead of just the images.

also… since it is showing on the screen shot.. i was wondering why the background behind the "@admin" the rounded corners seem to be cut off on the top..?

also… when the reloading that page you can see the "?" beside @admin is shown briefly then disappears.. i think it would be most helpful if the "?" did appear and was clickable to show the message "@admin is a unique identifier for admin that you can type into any message on this site. admin will be sent a notification and a link to your message any time you use it." for users who are not aware of how to use it. example: http://buddypressthemes.org/members/admin/

here is the live link to my profile page on my site: http://goo.gl/wjLWT

thanks very much in advance,

gina :slight_smile:

  • DavidM
    • DEV MAN’s Mascot

    Hi Gina,

    It doesn’t seem the classes got added to the images. Perhaps you could try the following instead?

    <img src="<?php bloginfo('template_url'); ?>/_inc/images/facebook.png" class="facebook">

    and

    <img src="<?php bloginfo('template_url'); ?>/_inc/images/twitter.png" class="twitter">

    Then you can separately style them with css:

    img.facebook {
    padding-top: 5px;
    }

    img.twitter {
    padding-top: 5px;
    }

    Could you give that a go?

    Cheers,

    David

  • DavidM
    • DEV MAN’s Mascot

    Hi Gina,

    Tammie’s been full up with updates, but I’ll see how I can help out while she’s busy!

    I’m really not sure why the @admin section is getting cut off, but the following should remedy that:

    div#item-header h2 {
    margin-top: 10px;
    }

    As for the info help section, I found that the message displays when commenting out line 31 of global.js as follows:

    //jq( 'span.highlight span' ).toggle();

    I’m really not sure why that’s occurring though, and I noticed the message got bumped down some distance after the initial display animation. If you can confirm the same happens on your site, I’ll see what I can find for a resolve there.

    I also noticed the facebook and twitter items are gone now. Did you decide not to go with that?

    Cheers,

    David

  • gina
    • The Bug Hunter

    my 1000th post :slight_smile:

    hi david.. ya i had to scrap my whole install and start from the ground up.. some plugin is not playing nice with the gridmarket theme.. haven’t figured it out.. but even after deactivating ALL plugins it still wouldn’t work so i got fed up and started over with a fresh WP install… which worked but.. well anyway… it’s a long story that i won’t bore you with :slight_smile: basically – still trying to figure it out..

    hence the missing twitter/FB icons.. least of my issues right now. BUT i will try this when i am back at the icon issue..

    thanks!

    g

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.