WPMU Wildcard Sub-Domains Lost

I have had some technical issues on the server side of the main site I am using your themes and plugins on. The server had to be restored after a security issue and everything seemed to come back ok except all the subdomains (user blogs) do not show correctly any more and go to the default apache page. The domain wildcard dns record is still in place. So I guess my real question is, is there a file somewhere that can be reconstructed to reflect all the existing blogs on the main domain?

  • aecnu

    Greetings nixwebo,

    Thank you for being a WPMU Dev member!

    So I guess my real question is, is there a file somewhere that can be reconstructed to reflect all the existing blogs on the main domain?

    Sorry to hear about the crash.

    It is my opinion that the missing info is/was in the database, specifically tables like globals that keeps track of all the blogs in wp_blogs. Not to mention each blogs own settings which will be distributed normally in thier own respective separate portion of the database.

    The question is now does your host have a back up copy of the database corresponding to the copy of the web site and if they do can/will restore that too.

    In any event, to help ease the pain and assist backing up and managing the databases, I offer you to download in what is in my opinion the greatest Database Management software of all time Navicat.

    Thanks again for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

    If this thread is not resolved because the suggested action did not work or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

  • Nick Simpson

    Ok I have still be struggling here. I can see that all of the tables including all the site date are intact in the db, what I need to find out is where the code is that tells wp to send a specific path to the correct part of the db. It seems like everything is there, but the site is just no longer redirecting to it. The wildcard dns record is there as well.

    Any suggestions?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.