WPMUDEV and WP Smush Pro causing errors on my other site

This is the error I see at the top of my dashboard: supplied for foreach() in /home/anthonyrburciaga/public_html/wp-content/plugins/wp-smush-pro/lib/class-wp-smush-admin.php on line 1903

I am not able to allow access to the site because it always sends me to a screen with random error codes like the one above.

Thank you!

  • Adam Czajczyk

    Hello Anthony,

    I hope you're well today and thank you for your question!

    Actually an access to the site seems to be granted and I was able to use it. I can see the error in your site's dashboard as well. That's a "warning" however so it should "block" the site. It may or may not affect site's performance (e.g. plugin's functions) but that's yet to be investigated.

    The first step would be to "get rid" of that message so it itself wouldn't affect the site but at the same time keep debugging enabled. I think there's this line in your site's "wp-config.php" file

    define('WP_DEBUG',true);

    If it's there please replace it with these lines:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);
    define('WP_DEBUG_DISPLAY',false);

    If that aforementioned line is not in your site's "wp-config.php" file please add these lines right above the "/* That's all, stop editing! */" line.

    Once this is done, the "error message" should be gone and you should be able to check your site whether it's working fine or not.

    Keep me informed please,

    Best regards,
    Adam