WPMUDev Dashboard Causing Yoast Issues

Hi,

All the info is here (https://github.com/Yoast/wordpress-seo/issues/6220) I opened a ticket to the folks at Yoast as assumed was an issue with their plugin.

If I disable the dashboard all is fine, enabled the shop pages on this site 500. If I disable Yoast and keep WPMUDev stuff on it works fine. But we need admins to have acces to Yoast, this seems to have happened post WP 4.7, but not 100% sure, we can grant access as required.

Note: This only affects logged in admins.

  • Rupok

    Hi Rob,

    I just activated WPMU DEV Dashboard, Yoast and WooCommerce in my test site running WordPress 4.7 but I could not regenerate your issue. I can see my WooCommerce Store archive and Single Product pages fine even though both Yoast and WPMU DEV Dashboard plugins are activated and configured. So I think, this is not a generic conflict, rather this is your site specific issue.

    Can you please try to regenerate this same issue on another site in another server? If you can regenerate please tell us the steps so we can try to regenerate this on our instances too. If we can regenerate, I'll ping our developer right away to take care of this.

    Thanks for the log data. From the debug data, it seems that your system is running out of memory. Can you please try increasing your allocated memory and check if the issue is still there? To increase your memory limit, you can check this guide: https://premium.wpmudev.org/blog/increase-memory-limit/

    Try to increase your memory at least 128MB and check if the issue is gone. If still there, please let us know. We will be glad to investigate further.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hey Rob,

    Hope you are doing good today. :slight_smile:

    There could be some other plugin that's is causing this conflict too, please keep the WPMU DEV Dashboard, Yoast, and WooCommerce activated, and check whether deactivating other plugins apart solves this issue, please test this with a default WordPress theme enabled.

    Regarding memory limit, please try a higher value for eg:512, so that your rules will be like this:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 180

    If you are still having issues, please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.