WPMUDEV Dashboard Crashed my install

My entire website went to 502 Error. Upon investigating the issue within my WPEngine dashboard I saw:
[Wed Feb 03 13:31:09.964359 2016] [:error] [pid 14744] [client 96.10.190.18:41719] [WPMU DEV Dashboard Info] Project Auto-Upgrade result for 119: Failed..., referer: http://valuepest.com/fleas-and-ticks-pest-control
[Wed Feb 03 13:31:31.106636 2016] [:error] [pid 14744] [client 96.10.190.18:41719] WPMU DEV error: Upgrade failed - error 1, referer: http://valuepest.com/fleas-and-ticks-pest-control
[Wed Feb 03 13:31:31.106731 2016] [:error] [pid 14744] [client 96.10.190.18:41719] [WPMU DEV Dashboard Info] Project Auto-Upgrade result for 119: Failed..., referer: http://valuepest.com/fleas-and-ticks-pest-control
[Wed Feb 03 13:31:52.396232 2016] [:error] [pid 14744] [client 96.10.190.18:41719] WPMU DEV error: Upgrade failed - error 1, referer: http://valuepest.com/fleas-and-ticks-pest-control
[Wed Feb 03 13:31:52.396310 2016] [:error] [pid 14744] [client 96.10.190.18:41719] [WPMU DEV Dashboard Info] Project Auto-Upgrade result for 119: Failed..., referer: http://valuepest.com/fleas-and-ticks-pest-control
[Wed Feb 03 13:32:25.119181 2016] [:error] [pid 9350] [client 96.10.190.18:41809] WPMU DEV error: Upgrade failed - error 1
[Wed Feb 03 13:32:25.119268 2016] [:error] [pid 9350] [client 96.10.190.18:41809] [WPMU DEV Dashboard Info] Project Auto-Upgrade result for 119: Failed...
[Wed Feb 03 13:32:46.224527 2016] [:error] [pid 9350] [client 96.10.190.18:41809] WPMU DEV error: Upgrade failed - error 1
[Wed Feb 03 13:32:46.224594 2016] [:error] [pid 9350] [client 96.10.190.18:41809] [WPMU DEV Dashboard Info] Project Auto-Upgrade result for 119: Failed...

So, I renamed the folder wpmudev-updates to wpmudev-updates_1 and everything came back up fine.
Seems your dashboard crashed the site?
Thanks.