WPMUDEV Dashboard NOT Working?

Hello Everyone

I have a problem with my wpmudev dashboard plugin. It seems to be broken,lol

First of all I included a pic on how I see the dashboard. My problem started on last week Friday when I got my membership reactivated (Happy to be Back) and wanted to do all the updates I have been missing. That is when I started to see when the wpmudev dashboard is not working properly.

I then tried to deactivate and reactivate the plugin, but still the same. Then I deleted the wpmudev dashboard plugin and downloaded a fresh set of files and reinstalled it again with ALL other plugins disabled, BUT still the same – nothing. Also the moment I deleted the wpmudev dashboard it showed me to download the wpmudev dashboard plugin BUT failed cause it said : "Cannot connect to host"

I then sent my host a support ticket and got the following from them:


Thank you for your patience up to now.

Please note that there are no features disabled on the server which currently hosts your account. We were able to log-in into your back-end with the provided credentials and indeed the plug-in you are using does not want to connect property to the internal server to fetch any updates/plug-ins/themes. However, we did not find any configuration options of the plug-in to check if the settings are correct. Additionally, we were unable to locate where exactly should the API key be inserted so the plug-in can work correctly. Due to these facts, we kindly advice you to contact the developers of the plug-in for further assistance and when you get a reply from them, if there is anything that needs to be done on the hosting side, we will gladly assist you.

Thank you for your understanding in advance, if you have further questions please do not hesitate to contact us.

Best Regards,

Vince Bennett

Technical Support Team

As you see their isn't any place to re enter my API Key. Also I tried on a fresh install of wordpress on the same server and when ever I want to enter my API Key it's giving me : "Invalid Key. Please try again"

So now I am left in the dark and in need of serious help. Any assistance would be very appreciated.


JP @MingleMooch