WPMUDEV Dashboard redirects without login.

I went to my WPMUDev Network Settings page today, and it prompted me to login. But the login page reloads without ever getting me back to the WPMUDEv dashboard properly.

I can login to the WPMUDev.org website, and my premium account is in good standing, so I thought I'd try an API key reset. No login. So I changed my password and tried login from my multisite with the new password, still no login. Interesting that if I use an incorrect password, your plugin tells me so, but when I use the correct password, the page refreshes and I am stuck at the "Let the Games Begin" login page.

I found a couple of threads related to cloud fare or SSL, but I use neither.

  • James Morris

    Hello dsader,

    I hope you are well today. Thank you for your question.

    There's a couple troubleshooting steps I'd like you to try to see if we can narrow down the cause of this problem.

    First, I see that you are running an older version of DEV Dashboard. While this isn't likely the source of the problem, it's always best to eliminate all possibilities. Would you please try updating to the latest version of WPMU DEV Dashboard (currently 4.3) via FTP then see if you can login?

    If that does not work, could you please run a plugin conflict test as outlined in the following article? This will eliminate the possibility of a conflict with another plugin. https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If that does not lead to a solution, could you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you have tried to login to DEV Dashboard, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then paste the contents of that file at http://pastebin.com/ and share the URL of the pasted output with us so we can examine it further.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

  • dsader

    Well, it looks like it indeed is a plugin conflict issue, when I moved all plugins out except the updated WPMUdev dashboard plugin, it came back to life.

    So now I will try to add plugins in combinations to see if I can reproduce the lockout.

    That might take some time, and I will look into my debug notices as they popup.

    So for now, it looks like I have a strategy, and an updated WPMUdev dashboard plugin.

    Thanks for the tips and encouragement. If I find further causes that would be useful to your plugin, I will post back.