WPMUDEV Dashboard update to v4.0.4 causes 500 - Internal Server Error

Dear Support,

I am experiecing endless problems trying to update to WPMUDEV Dashboard v4.0.4. This is really impacting on my business and causing me a lot of problems.

I am experiencing an error 500 - Internal Server Error. This appears after installing the plugin and then navigating back to the plugins list. I have now lost the ability to log into the admin function.

I have never had an error like this before with any other plugins.

Please advise ASAP.

Kind regards,
Will

  • Vaughan
    • Support/SLS MockingJay

    Hi Will,

    Hope you're well?

    Can you check your servers error logs to see if there's any errors listed there which might shed some light on what caused the error 500? You should be able to find them in your servers CPanel, or look for an error_log file in your website root (where wp-config.php resides) & /wp-admin folders.

    If you wish to get access back, you will need to use FTP.

    Navigate to /wp-content/plugins/

    Then delete the wpmudev-updates folder.

    Thanks

  • Elliot Charles
    • The Incredible Code Injector

    Hi Vaughn,

    Thanks for the prompt response and problem solving indicators. It is much appreciated.

    I have regained access to the admin function so I have cancelled the ambulance I called earlier.

    The message in the error log is as follows:

    [Mon Jan 25 11:11:24 2016] [error] [client 192.0.102.40] script not found or unable to stat: /home/xxxxxxxx/public_html/index.php

    As this is an open environment I have replaced my hosting account name with x's. If you believe this to be sensitive information then feel free to mark the conversation as private.

    Thanks in advance,
    Will

  • Vaughan
    • Support/SLS MockingJay

    Hi Will,

    That error message doesn't look related to this issue. Must be something else causing it.

    Can you create a file called info.php

    Add the following code to this file:

    <?php phpinfo();

    Then upload this file to your sites root where wp-config.php resides.

    This will allow me to view the PHP config of your server.

    Thanks

  • Vaughan
    • Support/SLS MockingJay

    Hi will,

    Can you try increasing max_execution_time in your php.ini

    Currently it's set at 120, could you increase the value to 300?

    max_execution_time = 300

    According to phpinfo, you should be able to find the php.ini in the following location:

    /home/zizzzite/public_html/www.e01b49.com/php.ini

    Hopefully that should fix it.

    However, we are due a new release of the dashboard plugin (most likely be tomorrow morning sometime when it's released, which might fix this for you, however, it's still worth increasing that max_execution_time to 300 or more to save issues further down the line.

    Hope this helps

  • Elliot Charles
    • The Incredible Code Injector

    Hi Vaughn,

    I have edited and saved the php.ini file located at /home/zizzzite/public_html/www.e01b49.com/ to reflected the value of 300. I am on shared hosting so I'm not sure whether that value will be acknowledged or overwritten by the smaller value of 120.

    As there is no WPMUDEV Dashboard on the installation anymore (deleted the folder via FTP earlier) I downloaded the WPMUDEV Dashboard v4.0.4 from yourselves and on trying to install the plugin I get the following message:

    You have used your space quota. Please delete files before uploading.

    I have over 20Gb remaining on the server and over 400Mb still available for the default site on the installation. I have never see this error before but it is not allowing me to install the latest version of the plugin.

    Would you propose I wait until the newer version of the Dahboard plugin is released to see if it fixes the issue?

    Many thanks,
    Will

  • Elliot Charles
    • The Incredible Code Injector

    Hi Vaughn,

    Great news on the new build. I'm looking forward to trying it.

    The site is not running the pro-site plugin.

    I can install a plugin from wordpress.org without any problems ... I just can't install a plugin from my hard drive. I have checked all the settings, doubled the network default, quadrupled the size available for the default site and I am still having problems.

    I wasn't experiencing this problem before. Do you think it could be related to deleting the WPMUDEV dashboard folder yesterday?

    Could I unzip the v4.0.5 plugin locally and FTP it over to the Plugins Directory? I do not know if this will interfere with the proper running of the WPMUDEV Dashboard plugin.

    Thanks in advance.
    Will

  • Elliot Charles
    • The Incredible Code Injector

    Hi Vaughn,

    While waiting for an update I tried the WPMUDEV Dashboard v4.0.5 plugin on a separate network. It works straight off without any hitches.

    The new dashboard and capabilities are incredible. Although I updated my subscription recently I have been wondering what value I will get from the subscription and I can say now I am really glad I renewed. You guys are clearly still alive and kicking, I'm looking forward to themes, plugins, seo, security, performance and backups from one development house. My life will definitely become easier.

    Please just help me get my main production site sorted and added to my WPMUDEV profile.

    Many thanks,
    Will

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    Deleting the folder shouldn't be causing this issue. But clearly something is.

    Can you send your details using the following contact form (select i have a different question from the dropdown.)

    https://premium.wpmudev.org/contact/

    Mark for attn: Vaughan
    Include a ref URL to this thread.

    Please include the following details;
    - Site login details (super-admin if on multisite)
    - FTP login details so I can take a look at the theme/plugin files.

    Thanks

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    It looks to be ok now, it had something to do with the SG cache plugin and memcached, I removed the object-cache.php file form wp-content temporarily, and then flushed all the cache.

    It all seems to be ok now. Object caching can cause a few issues with plugins that require remote access/Curl & stuff.

    You are correct though, the max_execution_time value seems to be locked by the host at 120.

    You might want to ask them to see if they can increase that to 300 to be safe though.

    If you have any further issues, do let us know :slight_smile:

    Cheers

  • Elliot Charles
    • The Incredible Code Injector

    Hi Vaughn,

    Superb job. One day you'll be running the country ...... at the very least you'll be keeping WPMUDEV customers very happy.

    Huge thanks for all your efforts and resolving the issue for me, it is very much appreciated.

    All good wishes,
    Will

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.