WPMUDEV Dashboard update to v4.0.4 causes 504 Gateway Time-out

Dear Support,

I upgraded to WPMUDEV Dashboard v4.0.4 on a multisite installation and I now cannot access the admin section of the website. I am effectively locked out of the network.

Message: "Gateway Time-out The gateway did not receive a timely response from the upstream server or application."

I applied the same plugin update to a second multisite network and I get the exact same error.

I ensured the auto update feature was turned off, as advised, before installing the update.

Thanks in advance,
Will

  • Sajid
    • DEV MAN’s Sidekick

    Hi Will,

    Hope you are doing good today :slight_smile:

    I just updated the plugin on my own site but did not get timeout error. It appears to be memory and maximum execution time issue.

    Please try increasing the memory and execution time as described in this article and then check again.

    Let me know how it goes :slight_smile:

    Cheers, Sajid

  • Elliot Charles
    • The Incredible Code Injector

    Hi Sajid,

    Thank you for your prompt response. I am on shared hosting so I am operating within certain restrictions. The following list indicates what the settings are for memory and execution time.
    I did not see any warnings on the update it self on memory and time execution, only that auto updates should be turned off.

    memory_limit = 256M
    max_execution_time = 240
    error_reporting = On
    max_input_vars = 5000

    I have tried again but the error remains.

    What would you recommend?

    Kind regards,
    Will

  • Elliot Charles
    • The Incredible Code Injector

    Hi Sajid,

    Not having heard back from you I decided to restore the whole network back to Saturday (the WPMUDEV Dashboard plugin v4.0.4 was installed on Sunday).

    I can now access the Admin section of the site which allows me to continue working.

    However, I had 8 plugin updates to install (3 WPMUDEV and 5 others). The 5 others have been installed without a problem. The 3 WPMUDEV plugins list as being available for update but do not include a tickbox next to the plugin. So I am unable to select the plugin and then click update.

    Please can you advise as it is a little unsettling no longer having the ability to update the WPMUDEV plugins.

    Thanks in advance.
    Will

  • Sajid
    • DEV MAN’s Sidekick

    Hi Will,

    Hope you are doing good today :slight_smile:

    I am sorry for delay on this ticket. Thanks for sharing the php memory and execution time settings with us. I also have same settings on my own website and latest WPMUDEV plugin is working perfectly fine for me.

    Also, we have just released 4.0.5 version of WPMU DEV Today. Please update to this version and then let me know.

    If you still got this issue then I will bring it to Developers attention to get his valuable feedback on this matter.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.