WPMUDev Hosting – Form Emails Coming from noreply@wpmudev.host

It looks like the emails coming from Gravity Forms on my installation are coming from noreply@wpmudev.host instead of the person who is contacting me through the forms.

The notification is set up correctly on the Gravity Forms setting, so I am assuming this is a bug with the hosting setup? Otherwise is there another setting that I am not aware of to resolve this?

Thanks!