WPMUDev, On localhost I deactivated some plugins to help

Hi WPMUDev,

On localhost I deactivated some plugins to help speed up trying to convert some pages to custom post types because the multi-select convert to post type option wasn’t converting anything.

I had no problem deactivating about 15 plugins. Then I decided to deactivate about 10 more and now my site is blank and I get the following debug errors, which I’ve never gotten before, so I don’t know what to do. I get one error on the backend of the site and one on the frontend.

My Fatal Error on the backend of the site:

Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 32 bytes) in /Users/Champion-iMac/Projects/x.com/wp-includes/pomo/translations.php on line 256.

Line 256 – 257 reads:

function translate($singular, $context=null) {
return $singular;
}

My Fatal Error on the frontend of the site:

Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 79 bytes) in /Users/Champion-iMac/Projects/x.com/wp-content/themes/dt-the7/inc/shortcodes/js_composer_bridge.php on line 548

Line 242 – 253 reads:

array(
"type" => "dropdown",
"heading" => "Separator & background color",
"param_name" => "separator_color",
"value" => array(
"default" => "default",
"accent" => "accent",
"custom" => "custom"
),
"std" => "default",
"description" => ""
),

Any ideas/troubleshooting? Please help.

Thanks,

  • PC
    • WPMU DEV Initiate

    Hey there Noahj,

    Thanks for posting on the forums and sorry to hear about the issues you are facing.

    Those are memory issues as your local site is out of memory. Perhaps due to deactivation of multiple plugins at the same time.

    How are you running WordPress ? Using MAMP ?

    If yes, here is how to increase the memory limit : http://blog-en.mamp.info/2009/09/increase-php-memory-limit-with-mamp-pro.html

    If you are not able to do that, please let me know how you are running WordPress and I will assist accordingly :slight_smile:

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers, PC

  • Noahj Champion
    • Site Builder, Child of Zeus

    Hi, PC! You're the champ!

    I am using MAMP and not MAMP Pro. I did not have the option from the instructions for Choose Menu -> File -> Edit Template -> PHP4 php.ini from the instructions page.

    So, I found the file manually and here is where it is for anyone else needing the same and screenshot attached.

    Applications/MAMP/bin/php/Your_Php_Version/config/php.ini

    (around line 232. as of today in php5.5.3)

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.