WPMUDEV plugin support matrix for PHP versions

Does WPMUDEV have any type of published support matrix showing which plugins are tested against which versions of PHP?

I ask because we are considering moving our host to PHP 5.6 and wanted to see if there was any type of starting point for compatibility testing. I would not expect this from 3rd party plugins necessarily, but at least for the WPMUDEV packaged plugins.

  • Timothy Bowers
    • Chief Pigeon

    Hey there.

    We're often held back from using newer PHP features because WordPress advertises it works on 5.2.4 and we want to remain compatible with them:

    https://wordpress.org/about/requirements/

    You can see the PHP versions used by WordPress here:

    https://wordpress.org/about/stats/

    We should work perfectly fine on higher PHP versions, our staff all have their sites on different environments with different versions, but if you do come across any issues, report them and we'll get a developer to look into it. :slight_smile:

    FYI, this would be better in the support area rather than members forums as it requires a response from our team. No biggie, moving it over now :slight_smile:

    Cheers.

    • Timothy Bowers
      • Chief Pigeon

      It could be a long list and probably not that beneficial as a customer simply expects it to work. Would also be a pain to maintain with every release checking with every staff member what they now have. From a marketing point of few, listing everything that it hasn't be tested with (which is essentially what would be happening by not mentioning it) could be a deterrent to people even trying it when in actual fact there wouldn't be an issue.

      If you do get an issue with a specific version we'll happy look into that for you.

  • Dan
    • Design Lord, Child of Thor

    OK, thank you all for the input. Timothy, I did have a case a couple months ago (might have been Snapshot Pro) where the WPMUDEV expert simply said "you need to upgrade your PHP". We were running 5.2 at the time. So as djohns said, it might be helpful to just have minimum PHP requirements listed for each plugin if a full matrix is not practical or needed.

    • Timothy Bowers
      • Chief Pigeon

      Now that you mention it, I recall some internal discussion on that. I suspect in that instance the requirement was from the third party service you was backing up to. I think it's Google (could be wrong on the service, I'll check) that required it with their SDK rather than us, but that's not the point I know, it's our product you're using to connect to their service.

      I'm gonna get our QA to look at this, she'll amend the docs accordingly.

    • Michelle Shull
      • DEV MAN’s Apprentice

      Hey Alex!

      I'm the QA, Tim sent up the bat signal. :slight_smile:
      I was unable to find a support ticket with your Snapshot/PHP5.2 compatibility issue, do you recall any details about what type of error you received or what went sideways? I'm happy to help you troubleshoot, and I can work with our dev to address any remaining issue.
      I test each release with each version of PHP from 5.2 - 7. I use the WAMP environment, so I've got WP test sites for single, sub-directory and sub-domain setups in each supported version.

      To defend our support team, not only because they're awesome co-workers, it's not a terrible idea to upgrade, regardless of what WP supports. PHP 5.2 was released in 2006, and even php.net stopped supporting it in 2011. I think you'll like 5.6, it's the most prevalent PHP version in the wild, it's stable, and it's still supported by php.net. All of our plugins which were updated or released since I took over, a little over a year ago, have been tested with 5.6.

  • Dan
    • Design Lord, Child of Thor

    OK, looking back at my notes it was actually with the Support System plugin. We couldn't activate it unless we moved to PHP 5.4 or later.

    But overall we are taking your advice and moving to 5.6 with a battery of internal testing.

  • Tyler Postle
    • CGO

    Hey Alex,

    Sorry for the delay here, thanks for letting us know which one it was. I just tested this out and can confirm it's still not working with PHP 5.2, I've reported this to our developer so it can get fixed up.

    Although, yes, definitely good call to get yourself upgraded to 5.6 :slight_smile:

    Hope you had a good weekend.

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.