wpmudev plugin updates not working

WP admin tells me Appointments+ is at version 1.5.2, WPMU DEV dashboard tells me there is an update for Appointments+ to version 1.5.6.
When I select update get an error that the plugin Appointments+ on my website is at the latest version.