WPMUDEV Updates Plugin Error

Morning,

Starting yesterday, I started seeing this error on my prod WPMU installation:

Fatal error: Cannot use string offset as an array in /mnt/base/www/wp-content/plugins/wpmudev-updates/update-notifications.php on line 616

Disabling the plugin (by moving that folder out of the plugins folder) resolved the issue.

Any thoughts? Would love to re-enable the plugin.

Stats:
WPMU 3.1.1
Multi-DB

Tim