WPSmush not smushing

I have been informed by the Smush plugin 3 different times that I have 285 images to smush. I have run the "super smush" function 3 different times, and it keeps coming back up as there being 285 images to smush. If I hover over the 0/285 to smush, a message pops up saying I have smushed 1694 images, and I don't have anywhere near that number of images on my site! I now have Hummingbird installed, and it is at 75% efficiency, and the thing is says I need to do is smush images. It doesn't seem to be working for me. Pleas help.
Once they are smushed, do they not stay smushed??

  • Predrag Dubajic

    Hi Kimberly,

    Thanks for granting access, I had a look at your site and looks like WP Engine caching was not showing the new status of the images, I have purged the cache and you can see now that all images are smushed.

    If I hover over the 0/285 to smush, a message pops up saying I have smushed 1694 images, and I don't have anywhere near that number of images on my site!

    If you ran the smushing process multiple times it's probably because of that, as it was sending images to smushing each time you clicked the smush button.

    I now have Hummingbird installed, and it is at 75% efficiency, and the thing is says I need to do is smush images. It doesn't seem to be working for me. Pleas help.

    About this, there are two kinds of reports for image optimization.
    ?
    1. Losslessly compressing - This one's is telling that image can be optimized and that's what smushing does.
    There are only 2 images with this report on your site and both of those are original images, not the thumbnails, and since in WP Smush you have disabled "Include my original full-size images " option it doesn't smush those images.
    ?
    2. Compressing and resizing - This shows that the images are resized via HTML and/or CSS

    The second one is what's reported for 3 images in your results and that's because your theme is loading 784x295 thumbnails below your home page slider but the actual HTML holder of that image is 320x124 so the image is resized with CSS to fit in that holder.

    Unfortunately this is not something Smush can deal with since the theme code is written in the way to call the larger image, and even though the image is compressed google doesn't like loading image larger than its holder, so this is something you need to check with the theme devs.

    Hope this all makes sense and clears things up a bit, if you have any followup questions let us know :slight_smile:

    Best regards,
    Predrag

  • Kimberly

    Ok, I think I fixed these things by changing the image size manually...
    Now I have run the Hummingbird Minimize program, and I have a message that says:
    "moving files between the header and footer of your page can break your website. We recomment tweaking and checking each file as you go, and if a setting causes errors, then revert the setting here."
    I am not sure how to read these results, and if I should "save" them!
    Thanks for your help.
    Kim

  • Adam Czajczyk

    Hello Kim!

    I'm glad you managed to fix the images issue.

    As for Hummingbird's minification.

    The message that you are getting is not an error message but a warning to make you aware of the fact that minification may (but that doesn't mean it will) break the site.

    The Hummingbird's minification is a complex process that involves:

    - "compressing" JavaScript and CSS files
    - merging them into less number of bigger files (as a result of minification the site may use e.g. 3 JS files instead of ten)
    - moving them from their original location to a header/footer of the site (that's often used to deal with famous "remove render-blocking resources" Google Page Insights message).

    There's unfortunately no way to "guess" which files should be minified/merged/moved because it's different for different setups and there's a countless number of WP + plugins + themes combinations around.

    That being said, a suggested way to deal with it would be as follows:

    - purge WPEngine's cache
    - enable minification by running "check files" and saving results
    - purge WPEngine's cache again
    - check the site to make sure if everything is still working fine

    Then, in case you spot any issues around the site, you'd need to try to identify which part of the site was affected: is it a CSS issue? does it come from a theme or some plugin? This may be difficult to achieve but it's doable. Then on "Minification" page you may disable "minify" switch and/or "combine" switch from files belonging to that identified theme and/or plugin.

    Alternatively (this may be simpler for you, I think), if the site breaks after minification is enabled try following steps:

    - don't disable minification but instead turn off "minify" and "combine" switches for all listed files
    - purge cache
    - check if the site is working fine (it should now)
    - switch on "minify" switch for each file one by one each time checking if the site works; if it stops working toggle the switch back to "off" position and skip to the next one on the list

    At some point you should end up with a fully working site with some files set to be minified and some set not to be minified but with a "combine" option set to off for all files. Then you would want to repeat above procedure for "combine" switch for all files.

    I agree that's a daunting task and may be time consuming but usually you need to do this just once and after its all set, the site should work nicely for you.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.