Wrong working hours in appointments +

Hi there,
I've been for several days trying to configure the working hours for my service but, unfortunately, I didn't find the way for it. I know you have several issues like mine, but I have not been able to find a solution for me.
I need to configure a work schedule on saturday and sunday, from 11:00 to 21:00 with 60 minutes working time and 30 minutes of break between sessions. Also I need a break from 2 pm to 5 pm both days. My working hours tab is now plenty of break lines that I can't delete and breaks are in the front despite I set them to no. This is the first plugin after several testing that suits my requirements, but if working hours are not working I can't work with it. Please, could you advise or explain what could be a workaround? Thanks.

  • LittleBlue

    Hi Alexander,

    I definitely deleted the plugin to delete all this erroneous break lines that were malfunctioning it. I couldn't find another way of deleting because no button exists for this.
    I reinstalled again and tried different configurations.
    The duration for my service could be something more than one hour and this is the reason why I wanted this half an hour between services. As it seems that breaks are not working fine, I tried a solution with service duration of two hours. This could suits me, and I managed to make work one break line for saturday (not sure how because all the previous time this was working wrong).
    So.. this could be a workaround for me but this arise to another problem: in the confirmation step, it is showing that service duration is 120 minutes when it is not. My question is, is it possible to edit this confirmation view to not show service and service duration? If so, could you give some tip in this? Until break hours functionality works correctly, I could accept this.

    Below images of my working hours and how it is shown:
    Thanks in advance for your help.

  • Alexander

    Hi @LittleBlue,

    I apologize for the delay here. I've tried this out on my test site, and I wasn't able to reproduce this issue. I tried with version 1.3.1 and version 1.4

    Can you try updating to 1.4 and advise if this makes a difference? If this doesn't work, would you mind sending me login info so I can take a look hands on? If this is ok, just send it through the contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Alexander Rohmann"
    - Include a link back to this thread
    - Include any relevant login information

    Best regards,

  • pxwm

    Hi @Alexander Rohmann - I hope you don't mind me making a suggestion

    Hi @LittleBlue

    Currently if you create multiple Breaks and set the 'Break?' field to 'Yes' then you decide it is not required and set back to 'No' the break line will still be displayed but also it will still use the rules within it.

    I found a work around as follows:-

    For all those multiple 'Break' fields you have set to 'No' make sure that the Start and End times are outside your working hours and then A+ will ignore the settings.

    I'm not sure if v1.4 has fixed this as I haven't yet upgraded my demo site to test.
    But if you haven't yet upgraded to v1.4 you may wish to try.

    However, as always before upgrading I would suggest you take a full back up of your site as well as your database so you have an option to rollback.

    I hope this helps
    Regards
    SteveB

  • LittleBlue

    Hi @Alexander and Steve,

    Thank you both for your support and this workaround for my problem with breaks. Sorry for arriving here so late but weekends are my only available days for working in my page.

    I've just updated to 1.4. I will test and let you know my feedback.

    Regarding the breaks, my original problem was that they were not working, and, after that, I couldn't delete them. I will start from a clear installation of 1.4 to check if now I'm able to use breaks correctly.

    Regards.

  • LittleBlue

    Hi again, my comments after v1.4.

    I tested only with saturday. I tried to create next schedule:

    1. Work from 11:00 to 12:00
    2. Free from 12:00 to 13:00
    3. Work from 13:00 to 14:00
    4. Free from 14:00 to 17:30
    5. Work from 17:30 to 18:30
    6. Free from 18:30 to 19:30
    7. Work from 19:30 to 20:30

    You can see screenshots with configuration and results. I don't know if I' doing anything wrong, but it is not respecting break from 14:00 to 17:30 and it sets availability for 17:00 when it shouldn't.
    Also I'm not able to delete breaks and, as Steve commented, the only solution for this is the workaround he proposed.

    Alexander, I'm going to manage a test user for you and let you know.

    Regards.

  • pxwm

    Hi @LittleBlue

    I've checked your Working Hours settings and I would suggest the reason your break time of 14:00 - 17:30 is not showing as 'Free' time is because you have the 'Break' field for this time set to 'No'.

    Could you please set to 'Yes'
    Then Save

    Then try.

    I've also noticed that you have a 'Service' that has a 60 min duration.
    This will mean that when your Break is working between 14:00 - 17:30 then this will not show an available slot from 17:30 to 18:30 as you have the 'Time period' rules set to the 'Service' duration and as this is 60mins it means that all appointment slots will start on the hour.

    Please let me know if this is an issue and I can advise how to correct.
    This would mean activating the 'Duration' Add-on then setting the 'Time Period' to the legacy setting so is controlled by the setting in the 'Time Period' field in the A+ 'General' tab.
    However if you change the 'Time Period' to say 30mins then this will allow appointments to be booked on the hour and half hour, so not sure if this would be an issue.

    Regards
    SteveB

  • LittleBlue

    Hi Steve, thank you.

    You can see the Break field to "No" because I changed it to test if the breaks were deleted when you select No, and I forgot to change it again to Yes.

    Regarding the break on 17:30 I think now I understand you. I check and now it is possible to have this break al 17:30, although now I have more slots than I expected. Anyway, you're right, it seems to work and I can manage with it.

    So, I think the only problem that still persist is the one with the breaks that are not deleted, but your proposed workaround works for me.

    Thank you very much both of you for your help and support.

    Regards.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.