WSOD on all subdomain blogs need Apache Vhost guide

It seems to me Apache2 guide isnt complete. I have multiple sites existing on Apache2.
Simply having the htaccess does not enable the *:80 hostnames on Apache 2.2

I have tried using Default Server directive but that is not working out either. I am a bit frustrated, can someone point me to the complete guide.

I don't have more than one IP so I need all Vhosts to work.

Thank you

  • Sajid

    Hi @abhishek

    Hope you are doing good today :slight_smile:

    I am sorry, but I am unable understand what is the issue exactly. Sorry!

    I could find following documentations on apache2 that might help you too.
    httpd.apache.org/docs/2.0/

    The server configurations are a bit complicated and require complete access to server for configurations and setup, that is beyond the level of support we can provide here. I suggest you to hire a professional to help you get this done.

    If you need any assistance regarding our plugins then feel free to post a reply or start a new thread.

    However, I am leaving this support request open for other member of community may be one of theme could help you figure it out.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • vangel

    Hi Sajid,
    problem is quite straightforward. It seems that the wildcard vhost for multisite only works if there is only one vhost in Apache on the same IP. Having any other hostnames causes problems. I am sure there is a proper way which you guys must know. Both the base domain example.com and other domains not mapped to WPMU work but anything under *.example.com seems to point to default server.

    I am quite familiar with Apache, not an expert but I already host 32 sites on production without issues. I just can't seem to understand why the config provided by WPMU does not work.

    Looks like I am on my own.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.