Yet another Broken Customizer with Mapped Domains problem

Looking at other posts about the WP customizer (customize.php) not working, I would have thought there was a fix out already. But alas, the customizer does not work for me with mapped domains.

I have an SSL backend and wildcard Cert, so I will not be setting admin or login mapping to anything other then original domain. Frontend is forced http as I have varnish serving http frontend.

Crossdomain autologin doesn't make any difference. I'm using 'Make' as the theme in use and would like to keep using it. So It is left off.

Currently, my site is open to support access for another issue if you'd like to check out what I mean.

Thanks!

  • Patrick
    • Support Monkey

    Hey there @Carmelo

    I hope you're well today!

    There appears to be more going on with your SSL cert than just the issue you reported here.

    I have logged into your site using the Support Access you granted and, anytime I try to access customize.php on your main site, I get the dreaded "cheatin, huh?" message after it tried to load for a couple of seconds.

    So there does seem to be an issue with the cookie sharing across mapped domains.

    I've notified our 2nd-level team of this issue to see if they can provide a workaround and, if not, we'll advise the developer of the situation so he can investigate.

  • Carmelo
    • Site Builder, Child of Zeus

    Hmm.. It started working when I changed the option "Would you like to force http/https in front-end pages:" on the Domain Mapping plugin to "No". It doesn't work on either other settings 'force http' or 'force https', but only works on 'No'.

    So yes, it seems to work now for the main site and subsites, but perhaps it's something WPmuDev should know about. Thanks for your help!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.