YET ANOTHER COURSEPRESS ERROR - too many redirects, plugin conflict

Im here on yet another coursepress problem...

I am getting the common, 'Too Many Redirects' error on a specific page of my site:

https://my.smartphotocourses.com/dashboard

1. If i rename dashboard slug to dashboard-fix or any other slug it fixes the redirect
2. I have re-saved permalinks without joy
3. I have ran the common plugin conflict test and been able to see that the conflicts is with coursepress

Access to my site has been granted for 2 weeks as you work on my billion and one other problems!

  • Tom

    Further notes that I should have mentioned.

    I cant just fix the issue by disabling coursepress plugin. I must first switch themes to any other theme, disable ALL plugins then reload the page and it works. if i then switch back to my theme it works.

    Just changing the theme does not fix the problem. twentysixteen and coursepress enabled still causes the issue.

    If I just switch themes and deactive JUST the coursepress plugin rather than all plugins the page just redirects to my.domain.com/hello-world__trashed

    I have tried all common fixes for the wordpress too many redirects problem.

    There seems to be some kind of problem with activating plugins. If i click select all plugins, the bulk actions activate then only the top 3 plugins activate.

  • Nastia

    Hello Tom ,

    Hope you are doing well today!

    From my end, I see " HTTP ERROR 404" as well, it looks like the page was deleted. I've resaved the permalinks on your site and looks like this solved the issue. You can load the Dashboard page again.

    May I activate the CoursePress plugin to check if the "Too Many Redirects" error will come back?

    There seems to be some kind of problem with activating plugins. If i click select all plugins, the bulk actions activate then only the top 3 plugins activate.

    Most likely there is a conflict with plugins on your site, do you see any errors after activating the plugins? If it is not a conflict with a plugin then trying increasing max_execution time. Th current one is set to 30 sec so the script probably times out before enabling the rest of the plugins.

    Add the following rule to .htaccess file to increase max execution time:
    php_value max_execution_time 180

    Please advise,

    Cheers,
    Nastia

  • Tom

    Nastia

    Yes its 404 until coursepress is activated or works depending on the page you checkout.

    Once coursepress activates its 'Too Many Redirects' again.

    No errors after activating plugins on the site although yesterday I deactivated all plugins and got the wordpress white screen of death.

    As far as I could work out the white screen of death was caused by the script created by yourselves.

    [01-Mar-2017 14:28:55 UTC] PHP Fatal error: Call to a member function plugin_url() on null in /home1/antennae/public_html/smart/mysmart/wp-content/mu-plugins/script-order.php on line 7

    See - https://premium.wpmudev.org/forums/topic/coursepress-pro-prerequisite-course-issue#post-1223491

  • Dimitris

    Hey there Tom,

    hope you're doing good and don't mind chiming in here! :slight_smile:

    I was able to resolve this issue by changing the "Student Dashboard Slug" value back to default "courses-dashboard". Please keep in mind that this slug is used if you choose the virtual page instead of another specific published page.

    As this is kind of a bug, I already reported that to our devs in order to fix it in a future release. Meanwhile, your /dashboard/ page renders successfully without any "too many redirects" error.

    As for the error coming from the MU plugin that I shared here
    https://premium.wpmudev.org/forums/topic/coursepress-pro-prerequisite-course-issue#post-1222533
    I think this is happening because I don't check if WooCommerce is active, so please feel free to replace it with the following snippet. You shouldn't experience any white screens when you deactivate WooCommerce after that.

    <?php
    function re_enqueue_scripts() {
      /**
      * Check if WooCommerce is active
      **/
      if ( in_array( 'woocommerce/woocommerce.php', apply_filters( 'active_plugins', get_option( 'active_plugins' ) ) ) ) {
        global $woocommerce;
        $woocommerce_version = function_exists( 'WC' ) ? WC()->version : $woocommerce->version;
        $woocommerce_settings_deps = array( 'jquery', 'jquery-ui-datepicker', 'jquery-ui-sortable', 'iris', 'jquery-ui-dialog', 'chosen' );
        wp_dequeue_script( 'woocommerce_settings' );
        wp_enqueue_script( 'my_woocommerce_settings', $woocommerce->plugin_url() . '/assets/js/admin/settings.min.js', $woocommerce_settings_deps, $woocommerce_version, true );
      }
    }
    add_action( 'wp_print_scripts', 're_enqueue_scripts', 9999 );

    Reference: https://docs.woocommerce.com/document/create-a-plugin/#section-1

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.