Yoast SEO Conflict With Support System

Hello,

I've just been troubleshooting the following issue:

- On a multi-site install, site administrators are unable to save the meta description in the Yoast SEO meta box
- The admin user can edit the description, however after saving the post, the description reverts back to it's previous value
- Super Admins are able to update the meta descriptions as normal

After kicking off with the usual default theme and one by one plugin activation, I have found that this issue only occurs when the WPMU's Support System Plugin is also Network Activated.

I'll raise this with Yoast as well but if the WPMU devs could look into it as well that'd be grand.

Thanks,

  • Dimitris
    • Support Star

    Hey there Dominic,

    I trust you're well today and thanks for reaching us! :slight_smile:

    I just tried to replicate those issues you kindly shared with us in a test environment and I can truly confirm those. It seems that there's no error in debug log file or in console though. :thinking:

    I already created a bug report for our dev team and I'll keep you posted as soon as we've got some development about it. Your patience is highly appreciated here though, as our devs are having longer response periods than us here in support forums.

    Warm regards,
    Dimitris

  • Dominic
    • The Incredible Code Injector

    Hi Dimitris,

    Yes I couldn't see any obvious errors, after I spent the time finding the plugin conflict I haven't had much time to look at the code, but my guess there is something either permissions related or something is interfering with a save_post hook.

    Anyway, if I get time I'll look and pass some more information across.

    Thanks,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.