You are not authorized to access this page? TT Marketpress FrontEnd!

Hi,

I have received the following error after creating a vendor subscription and allowing access to the appropriate pages in Membership.

You are not authorized to access this page.

I can access as super admin and when I switch to WP Theme Twenty Thirteen I can then. But when using FrameMarket and GridMarket I cannot. I turned off all plugins excepet TT FrontEnd when testing FYI. I concluded the problem being withing FrameMarket and or GridMarket.

Please help me, I am so close to completing my store front.

Thanks a Million,
Nicholas

P.S. I have support access enabled in Dev-Dashboard and I have multisite enabled.

  • Tyler Postle

    Hey Nicholas,

    Hope you're doing well today!

    I will have to see what access rules you have set for your vender membership in order to replicate this as just signing up for a membership with gridmarket active seems to work fine for me.

    I see you granted support access; however, the token is invalid. Can you revoke then regrant the access? That should fix the issue then I can login and take a closer look :slight_smile:

    Look forward to hearing back!

    All the best,
    Tyler

  • Tyler Postle

    Hey Nicholas,

    Thanks for the quick reply and granting access :slight_smile:

    You may have noticed that I created a site, I'm noticing a few other issues here. It seems your emails aren't being sent, I tried signing up for a site through /wp-signup.php and the confirmation email never sent.

    Also, the site that I created manually from the network backend just gives a white screen. I'm thinking this is because www is in your url. You will likely want to switch this to just non-www as it is more multisite friendly.

    For the emails, can you try deactivating TT Frontend then doing a test sign up so we can see what might be affecting that? If it's still not sending email then it could be a server side issue and then you can switch to sending your emails through SMTP: https://wordpress.org/plugins/easy-wp-smtp/

    Reason I want to create a new site is because I want to see if when an admin creates their own site if they are able to visit the my-store page.

    Look forward to hearing back Nicholas!

    All the best,
    Tyler

  • Nicholas

    Hello,

    1. I don't see your store.
    2. Membership was turned off. This may be the reason why you did not receive a email.
    3. I have registered myself as a site admin and was not able to enter the "My Store" page. That is why I asked for help.
    4. I want all stores to be created from the FrontEnd.
    5. I absolutely do not want any site creation from the back end nor do I want members to ever see word press login screens and logos.

    Please help me resolve this issue.

    Reason: I need the site up and running by the end of November.

    Note: All WPMU themes and plugins should work together with WordPress. I am sorry I am having all these issues with compatible software.

    Regards,
    Nicholas

  • Tyler Postle

    Hey Nicholas,

    Thanks for your reply.

    If you go to My Sites > Network admin > Sites. Then you will see the site I created. You should also notice that it isn't accessible. Are you saying that when you switch to the default 2014 theme that you're able to access this site?

    I think the first issue that needs to be resolved here is making it so new sites are accessible, whether it's frontend or backend we need to make sure that new sites are going to be able to be accessed. Then we can start blocking access to the backend.

    I know that TT MarketPress Frontend can come with quite a few coding adjustments that they ask you to add in.. depending on the tutorial you are using. Have you added any custom code in?

    Look forward to hearing back Nicholas so we can get this all sorted. I also just want to note that TT MarketPress Frontend plugin is not affiliates with us in anyway, so any issues pertaining to that - our development team likely won't be able to resolve; however, we will help wherever possible!

    Talk to you soon.

    Cheers,
    Tyler

  • Nicholas

    Hi Tyler,

    1. When I try to view your site it is a blank screen like you said.
    a. The theme is currently the Default WP 2013.
    b. I have swithched to FrameMarket with GridMarket child theme and I was still not able to access your site. (Still Blank Screen)

    2. I have not made any custom coding changes. Do you have a link to those tutorials? Or a link to the coding that I can change?

    3. Should we unistall and reinstall WordPress and start new?

    Thanks,
    Nicholas

  • Tyler Postle

    Hey Nicholas,

    Hope you're doing well today and thanks for your reply.

    Starting new might be a good idea, we could take out the www from the db but if you don't mind starting fresh then it might just be easier to do. Generally having the www in a multisite causes issues.

    2. I have not made any custom coding changes. Do you have a link to those tutorials? Or a link to the coding that I can change?

    This one that I've seen members use: http://mp-frontend.info/wordpress-marketplace-tutorial/build-an-etsyebay-like-marketplace/

    Keep in mind it is old and outdated and you will likely run into some issues, you've been warned :p

    Let me know when you have the new site setup without www, then we shouldn't be getting that blank screen anymore on new sites.

    Look forward to hearing back!

    All the best,
    Tyler

  • Nicholas

    Hi Tyler,

    I have cleared my wordpress directory and started fresh by reinstalling wordpress, marketpress, multisite, membership, framemarket, tt marketplace frontend, and I have the same result before.

    After creating an account and try to access the my store page it says I dont have authorization.

    Please, let's trouble shoot this and fix this. It works with WP Default but I need it to work with FrameMarket.

    Should I try the custom code?

    Please Advise,
    Nicholas

  • Jack Kitterhing

    Hi there @Nicholas,

    Hope you're well today!

    I've been looking into your site and noticed quite a few issues.

    Multiple functions being used that have been deprecated since WordPress 2.5 and up.

    A redirect loop on the registration page once you submit your username/password (it registers the account, but just shows a redirect loop).

    The TT MarketPress front-end plugin is extremely outdated and I'd highly recommend not using it, it's outputting multiple warnings and hasn't been updated since last year for WordPress 3.6, if development isn't continued on it, in another six months, it might not work at all :slight_frown:

    CSS isn't loading on subsites at all.

    Can you send me the following please so I can take a closer look at this

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thank you!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.