You need Upfront core at version v1.4 or

Hi,
My plugin version seems to be too old.
"You need Upfront core at version v1.4 or better for Upfront Builder to work properly".
After following the link, choosing the plugin 'spirit", I get the plugin window.
Then, I choose "read more" -> upfront 1.7 -> no download, but my account window is displayed.
What can be wrong?
With kind regards,
Wim

  • Sajid

    Hello webmanager,
    Hope you are doing good today :slight_smile:

    It appears that you have not installed Upfront Parent theme framework. That is required for Upfront Builder and Spirit child themes.

    Please go to WPMU DEV -> Themes and install any theme like Spirit from there automatically instead of manually. This will make sure all necessary components gets downloaded too.

    If you continue getting this issue then please enable support staff access so I could take a closer look.

    To grant access go to WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Sajid

    Hello webmanager,
    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. I tried to install Spirit theme on your site from WPMU DEV -> Themes but get permission error.

    That means, you are on a host that requires FTP credentials for udpates and automatic installation.

    I then tried to manually install this theme and parent one from Appearance -> Themes -> Add New but got same error asking for FTP details, that I don't have.

    To fix this issue, please add the following code in your wp-config.php file, before the line that says stop editing and happy blogging.

    define(‘FS_METHOD’, ‘direct’);

    Now go to WPMU DEV -> Themes, find spirit or any other child theme of your choice and install. This will install theme and also upfront parent framework on your site.

    If above don't work for you then try adding following code in wp-config.php file replacing the above mentioned code. MAKE SURE you replace username, password and host with your FTP credentials in below dummy code.

    define('FS_METHOD', 'ftpext');
    define('FTP_BASE', '/var/www/vhosts/blockdias-gentbe/blockdias-gent.be/wwwroot/');
    define('FTP_USER', 'username');
    define('FTP_PASS', 'password');
    define('FTP_HOST', 'host');
    define('FTP_SSL', false);

    Once done, save changes and upload to your server and then try to install Spirit theme from WPMU DEV -> Themes again.

    In case, above method does not work for you then please send in FTP and WordPress admin details directly via our secure contact form and I will configure it for you manually.

    You can send the requested details via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.