You'll need Google Maps plugin installed and activated for Events Maps Options add-on to work

I installed the Events plugin.

I activated the Events Map Options.

At the top of the page in the dashboard it says:

You'll need Google Maps plugin installed and activated for Events Maps Options add-on to work.

However that plugin is THREE YEARS old!

I'll never install a three year old plugin.

I installed a plugin that is up to date with out 3.7.1 WordPress installation.

And I still get the message at the top of every dashboard page.

WPMUDEV promises that all plugins will work with the current version of WordPress.

How does this work with Events which relies on a way out of date plugin for Events to fully function?

Thank you for the amazing plugins.

I need to get this one working with the current version of WordPress.

Chris