Your domain does not appear to be publicly...

Hi, I am trying to activate "MONITOR YOUR WEBSITE" but I'm getting:
"Your domain does not appear to be publicly accessible on the Internet. We can only monitor the uptime of public websites."
This hasn't happened on other sites on the same server.

  • Sajid
    • DEV MAN’s Sidekick

    Hi Carl,
    Hope you are doing good today :slight_smile:

    This error occurred mostly on localhost websites. Could you please share the link of your website here so I can see if its accessible or not.

    Also, make sure you don't have any redirects or any maintenance/coming soon plugin installed.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • Nastia
    • Support Rock Star

    Hello Carl

    I see your domain name now

    Would you please try to activate monitoring from the Hub:
    https://premium.wpmudev.org/hub/my-websites/

    In your WordPress Admin->Settings->General, can you please check if the Site URL and Home URL schema is http instead of https?

    Would you please grant support access from your Dashboard > WPMU DEV > Support so that I can check?

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Nastia

  • Nastia
    • Support Rock Star

    Hello Carl

    I hope this answer finds you well!

    I have deleted the credentials you posted above. Please do not post your site credentials in the public forum. Anyone can access with them to your site.

    I would advise to change the password right away.

    Also with the account you created I don't have access to the Hummingbird plugin, I guess that this account has a Subscriber user role:

    Would you please send to us your super admin credentials so I can have a closer look?

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Nastia"
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Thank you!

    Cheers,
    Nastia

  • Nastia
    • Support Rock Star

    Hello Carl

    Thank you for sending your credentials to us, however, as I've mentioned in the above post, this account doesn't have Super Admin or Admin privileges. So unfortunately, I do not have access to check the Hummingbird plugin from your site. Please see the screenshot:

    Would you please set this account as administrator and provide admin privileges? Navigate to All Users > click on Edit, under the user's username.

    Change the account user role that you have sent to us, to Administrator ;ike it's shown in the attached screenshot:

    Thank you!

    Kind Regards,
    Nastia

  • Carl
    • The Incredible Code Injector

    I think I can add something further to the mystery. I just added the site to Google webmasters and it can't read the pages... "Redirected". I have checked cPanel and there are no redirects, subdomains, addon domains or anything. Any clue?

  • Sajid
    • DEV MAN’s Sidekick

    HI Carl,
    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. I tried to enable uptime monitoring from Hummingbird -> Uptime and get following error.
    Uptime error 500: Unknown Error

    Our uptime monitoring service will only work if it gets HTTP 200 status code in return. If it gets any thing else like 301 or 500 then it would assume the site is not accessible.

    So now we need to figure out and fix the 500 internal server error to make it work. 500 is most mysterious error code that may cause due to number of reasons. In WordPress most common reason is when the server hits the maximum memory limit or maximum execution time runs out.

    First of all try to increase the memory limit, execution time and post_max_size as well as described our blog article.
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • Nastia
    • Support Rock Star

    Hello Carl

    I hope you are doing well today!

    The Uptime Monitor will not work if there are any redirects. It's strange that the Google Webmaster is mentioning that the pages are redirected.

    Let's make sure this is not a conflict with another plugin. Please run a quick check, deactivate all the other plugins except the Hummingbird.

    Try to enable the Uptime monitor again.

    If the Unknown Error is still there, please place the following code inside the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Go to Hummingbird > Uptime Monitor and try to enable it again. After this all errors will be saved in the debug.log file inside the /wp-content/ directory. Please post here if you see any errors.

    In case there are no errors, please post here the content of your .htaccess file so we can have a closer look.

    Let us know how it went!

    Cheers,
    Nastia

  • Carl
    • The Incredible Code Injector

    Hi, I turned off plugins but that didn't solve it.
    I put the code in config.php

    I retried Uptime Monitor and got:
    Unknown Error
    TRY AGAIN SUPPORT

    And enabling it from the Hub:
    Your domain does not appear to be publicly accessible on the Internet. We can only monitor the uptime of public websites.

    I don't see a .htaccess in the root files.

  • Nastia
    • Support Rock Star

    Hello Carl

    The Pingdom tools mention that there are page redirects on your site. The Uptime can't be monitored when there are redirects.

    Please put the following PHP code to the functions.php file of your current theme:

    if( function_exists( 'rel_canonical' ) )
    {
    remove_action( 'wp_head', 'rel_canonical' );
    }

    That should remove canonical redirects. Before making any changes, please keep a backup of the functions.php, so you could restore it back in case something will go wrong.

    If this will not solve the issue, please try to reganarate the .htaccess file by navigating to Settings > Permalinks and just click on Save Changes button.

    Check if the .htaccess files appeared inside your directory. If you still can't find it, than there is a possibility that it might be hidden. Please contach with your Hosting provider, so they could provide you access to this file.

    I hope this helps!

    Cheers,
    Nastia

  • Carl
    • The Incredible Code Injector

    Tried the above. Not fixed. I am contacting the host supplier.

    I get this "Your domain does not appear to be publicly accessible on the Internet. We can only monitor the blacklist status of public websites."

    When activating BLACKLIST MONITORING as well.

  • Nastia
    • Support Rock Star

    Hello Carl

    Thank you for resenting your credentials!

    Our developers looked at your site and turns out your site is not accessible from app1.
    Neither accessible from Pingdom. Please see here:
    http://dnscheck.pingdom.com/?domain=designerfabric.com.au

    You can see detailed errors here, http://mxtoolbox.com/SuperTool.aspx?action=dns%3adesignerfabric.com.au&run=toolpage

    Please contact with your host providers to resolve these issues.

    Let us kow how it went!

    Kind Regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.