Your SEO crawl has timed out due to an unknown error

At first time I received the following message when I've tried to run URL Crawler:
Your SEO crawl has timed out due to an unknown error. Please try again or contact support.

After few attempts to run it I now see another error:
Processing timed out.

  • Adam Czajczyk

    Hi Heiki,

    I hope you're well today and thank you for your question!

    Checking crawler logs on our end suggest that even despite the timeout message, crawler did complete the crawl. However, when I checked your site I wasn't even able to run start it again to see how it behaves so I'd say there is something interfering.

    That being said, I've noticed that you got CloudFlare implemented and whenever I try to start a new crawl, it's actually a CloudFlare that redirects me back to the "SmartCrawl -> Sitemap -> Sitemap" page, which means that the request doesn't even reach your WP install actually.

    I'm assuming that this might be related to the original issue as well but even if not, it doesn't let me properly test the case. Having said that, I'd like to ask you if you could, please, login to your CloudFlare dashboard and switch it to the "dev" mode for the site temporarily.

    This would bypass CloudFlare so all the browser requests would be hitting your WP install directly. This way I could test it further and hopefully this would reveal if the problem is related to CloudFlare itself (we would then have to examine its current settings in details) or not (and in that case I'd "dig deeper" into your site).

    Let me know when CF is set to "dev" mode, please, and I'll continue working on this.

    Best regards,
    Adam